H3C WLAN本地转发实验

本文最后更新于 2024年3月25日 中午

简介

基于 H3C HCL Cloud 搭建测试。

使用一个AC控制三个AP,业务VLAN为100,AP管理VLAN为50。

实验拓扑

实验步骤

核心交换机配置

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
vlan 50
#
vlan 100
dhcp server ip-pool VLAN100
gateway-list 192.168.0.1
network 192.168.0.0 mask 255.255.255.0
dns-list 1.1.1.1
forbidden-ip 192.168.0.1
forbidden-ip 192.168.0.2
forbidden-ip 192.168.0.3

interface Vlan-interface100
ip address 192.168.0.2 255.255.255.0
dhcp server apply ip-pool vlan100
interface GigabitEthernet1/0/1
port link-mode bridge
port access vlan 100
combo enable fiber
#
interface GigabitEthernet1/0/2
port link-mode bridge
port link-type trunk
port trunk permit vlan 1 50 100
port trunk pvid vlan 50
combo enable fiber
#
interface GigabitEthernet1/0/3
port link-mode bridge
port link-type trunk
port trunk permit vlan 1 50 100
port trunk pvid vlan 50
combo enable fiber
#
interface GigabitEthernet1/0/4
port link-mode bridge
port link-type trunk
port trunk permit vlan 1 50 100
port trunk pvid vlan 50
combo enable fiber
#
interface GigabitEthernet1/0/7
port link-mode bridge
port access vlan 100
combo enable fiber

AC开启Web管理

1
2
3
4
5
6
7
8
9
10
11
12
ip http enable
ip https enable
# 开启Web服务
[H3C]local-user admin
[H3C-luser-manage-admin]password simple Abc@123456
[H3C-luser-manage-admin]service-type http https
[H3C-luser-manage-admin]authorization-attribute user-role network-admin
# 创建登录管理用户
interface GigabitEthernet1/0/0
port link-mode route
ip address 192.168.56.122 255.255.255.0
# 配置Web管理接口,与本机打通网络。

AC配置AP DHCP 开启AP自动接入。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
sysname AC1
# 配置主机名
vlan 50
vlan 100
# 创建VLAN
dhcp enabled
# 开启全局DHCP
dhcp server ip-pool ap-mg
gateway-list 192.168.50.1
network 192.168.50.0 mask 255.255.255.0
dns-list 1.1.1.1
forbidden-ip 192.168.50.1
# 配置AP管理网的DHCP服务器,配置网关为AP,配置网段范围、DNS、保留IP。
interface Vlan-interface50
ip address 192.168.50.1 255.255.255.0
dhcp server apply ip-pool ap-mg
# 配置AP管理网三层接口,配置IP,应用DHCP。
interface GigabitEthernet1/0/23
port link-mode bridge
port link-type trunk
port trunk permit vlan 1 50 100
# 配置与核心交换机二层接口,允许 50 100VLAN通过。
wlan auto-ap enable
# 开启自动AP功能
wlan auto-persistent enable
# 使用自动AP固化功能后,可以对固化后的手工AP进行配置。

无线模板

1
2
3
4
5
6
7
8
wlan service-template songxwn_st
ssid songxwn.com
vlan 100
client forwarding-location ap vlan 100
service-template enable
# 配置无线模板 songxwn_st,SSID名字为 songxwn.com ,默认VLAN为100,配置本地转发,VLAN为100。
# 最后开启此模板。
# 注意:未开启链路认证,因模拟器手机无法连接加密的认证。

创建并上传map文件

map文件用于给AP增加配置,添加vlan,修改上联接口的vlan类型等。

本地转发需要增加VLAN。

将下面字符保存文件为apcfg_songxwn.com.txt ,上传到AC1的flash:/ 目录下。(可通过Web上传)

1
2
3
4
5
6
7
8
sys
#
vlan 100
#
int g0/0/0
port link-type trunk
port trunk permit vlan 100
#

查看已注册的AP

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
<AC1>display wlan ap all
Total number of APs: 3
Total number of connected APs: 3
Total number of connected manual APs: 3
Total number of connected auto APs: 0
Total number of connected common APs: 3
Total number of connected WTUs: 0
Total number of inside APs: 0
Maximum supported APs: 60000
Remaining APs: 59997
Total AP licenses: 60000
Local AP licenses: 60000
Server AP licenses: 0
Remaining local AP licenses: 59997
Sync AP licenses: 0
AP information
State : I = Idle, J = Join, JA = JoinAck, IL = ImageLoad
C = Config, DC = DataCheck, R = Run, M = Master, B = Backup
AP name APID State Model Serial ID
8afa-b141-0200 1 R/M WA6320-HCL H3C_8A-FA-B1-41-02-00
8afa-b368-0300 2 R/M WA6320-HCL H3C_8A-FA-B3-68-03-00
8afa-b50f-0400 3 R/M WA6320-HCL H3C_8A-FA-B5-0F-04-00

# 当配置好VLAN、接口配置、DHCP、AP自动上线功能后。就可以查看到有三个AP已注册到AC.
# 使用wlan rename-ap 命令可重命名AP

创建AP组并关联无线模板

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
wlan ap-group apg1
ap 8afa-b141-0200
ap 8afa-b368-0300
ap 8afa-b50f-0400
# 创建AP组,关联AP。

ap-model WA6320-HCL
map-configuration flash:/apcfg_songxwn.com.txt
# 进入型号WA6320-HCL,关联本地map文件。(因为模拟器的AP型号为此)

radio 1
radio enable
service-template
radio 2
radio enable
service-template
# 进入Radio1/2 开启并关联无线模板songxwn_st,指定VLAN 100.

验证手机

选择任意一个手机,选择配置。

连接WIFI、开启DHCP获取地址,ping核心交换机。

获取到地址、ping通即可确认配置无问题。


H3C WLAN本地转发实验
https://songxwn.com/H3C-WLAN-LocalFA_LAB/
作者
Song
发布于
2024年3月25日
更新于
2024年3月25日
许可协议